チュートリアル:カスタム列を使用した Explore モデルの拡張

このチュートリアルに従って、Guidewire が作成した Explore モデルを Data Studio のカスタム列で拡張します。

初めて Explore の使用を開始した場合、Guidewire が作成したテーブル、モデル、Liveboards、および検索結果には、Guidewire が分析およびレポートのユースケース用に手動で選択したフィールドが含まれています。ただし、以下は含まれません。
  • お客様の InsuranceSuite の拡張フィールドとテーブル
  • お客様のユースケースに固有の、その他の InsuranceSuite ベースコンフィギュレーションフィールドとテーブル
ただし、これらのフィールドは、Data Studio で、レプリケートされたデータテーブルと動的に生成されたデータセット内で使用できます。Explore でこれらのフィールドを使用するには、このステップバイステップのチュートリアルに従って、Guidewire が作成したモデルを Data Studio からの追加の列で拡張してから、その列を Liveboard に追加します。
注: Guidewire が作成したモデルを使用していない場合は、代わりにData Studio データセットからの Explore モデルの作成 を参照してください。
このチュートリアルでは、次の手順を実行します。
  1. 拡張列を使用して Data Studio にデータセットの新しいバージョンを作成します。
  2. そのデータセットを Explore に公開します。
  3. 拡張データセットを含む新しいバージョンの Explore モデルを作成します。
  4. 新しいバージョンの Liveboard を作成し、拡張列をグラフに追加します。

開始する前に

  • Data Studio および Explore にアクセスできる必要があります。
  • 以下の役割を持つ 1 つ以上の Explore グループに属している必要があります。
    • 接続管理
    • データモデル管理
    • すべてのユーザーと共有
  • どのようにデータセットが Data Studio から Explore まで公開され、視覚化のために準備されるかを理解するために、Explore でのモデルの操作 を読みます。

手順

手順 1: 拡張対象を決定する

このタスクについて

まず、目標を決定する必要があります。Explore モデルを参照し、自身のユースケースに対して不足しているものを特定できます。次に、Data Studio から追加する列を決定します。モデルは複数のテーブルで構成されるため、最終的にどの特定のテーブルに列を追加するのかを決定する必要があります。

手順

Explore モデルに不足しているものの特定
  1. Explore のドキュメント を使用して、自身のレポートおよび分析のユースケースとの関連性が高いベースコンフィギュレーションに Explore モデルを特定します。
    このチュートリアルでは、ユースケースの例としてクレームの保険金支払を使用します。関連するコンテンツは、Explore for Claims の財務インサイト、具体的には GW - クレームの損害財務 - 暦年モデルです。
  2. Explore モデルの既存の属性と数値データを確認し、自身のユースケースに不足している可能性があるものについて検討します。モデルの列のリストは、次のいずれかの方法で表示できます。
    オプション説明
    モデルデータディクショナリ

    Explore ドキュメントから、GW - クレームの損害財務 - 暦年モデルのデータディクショナリを開きます。

    Explore アプリ
    1. [データ]データベースアイコン ワークスペースに移動し[データオブジェクト] > [モデル] > [GW - クレームの損害財務 - 暦年]を選択します。
    2. [列]を選択して、使用可能なフィールドを表示します。
    3. モデルを使用するビジュアライゼーションを確認するには、[依存]を選択し、暦年損害分析 Liveboard を選択します。
    このチュートリアルでは、詐欺を示す属性を追加します。
Explore で使用可能な列の参照
  1. Data Studio で拡張作業を開始する前に、関連する列が Explore でまだ使用できないことを再確認してください。モデルを構成するディメンションテーブルには、最終的なモデルに含まれていない他の列が含まれている場合があります。また、Explore には、モデルにまったく結合されていない他のディメンションテーブルもあります。
    1. Explore の[データ]データベースアイコン ワークスペースに移動し、 [データオブジェクト] > [テーブル]を選択します。
    2. 関連する列が含まれている可能性のあるテーブルを探して開きます。
    3. その[列]を参照します。列を検索するには、[詳細] > [TML を編集] > [Find]を選択します。例えば、efr_dim_claim テーブルには、モデルに含まれない追加の列(tn_weather )などがあります。ただし、詐欺を示す列はありません。
    必要な列が Explore で使用できる場合は、Data Studio を使用する必要はありません。手順 6:モデルの新しいバージョンを作成するまでスキップします。
Data Studio から追加する列の決定
  1. Data Studio で、InsuranceSuite からの属性と数値データを調べます。自身のユースケースのために Explore モデルに追加すると便利なものを特定します。
    1. Data Studio データディクショナリを開きます。『 Data Studio Guide』を参照してください。
    2. [クレーム]カテゴリで、ディメンションデータセットまたはファクトデータセットを参照します。このチュートリアルでは、dd_loss_claim_trv データセットから tn_fraudindicator_ext 列を選択します。
拡張する特定のテーブルの決定
  1. モデルを開きます。Explore の[データ]データベースアイコン ワークスペースに移動し[データオブジェクト] > [モデル] > [GW - クレームの損害財務 - 暦年]を選択します。
  2. [結合]を選択します。
    ファクトテーブルに結合されているすべてのディメンションテーブルを示す図が表示されます。このチュートリアルでは、efr_dim_claim を拡張することにします。この列はもともと Data Studio の dd_loss_claim_trv ディメンションから取得されているため、tn_fraudindicator_ext 列に関連しています。

ステップ 2:Data Studio で新しい拡張データセットを作成する

手順

  1. Data Studio を開き、[インベントリ]に移動します。
  2. すべてのフィルタをクリアし、拡張する Explore のテーブルの名前 efr_dim_claim を検索します。
  3. efr_dim_claim データセットカードで、省略記号を選択して[名前を付けて保存]を選択します。
  4. クエリの名前と説明を編集し、[保存]を選択します。
    1. 事業名: Explore クレームディメンション V1
    2. 名前:efr_dim_claim_v1
    3. 説明:詐欺インジケータで拡張されたクレームディメンション
  5. [種類] > [クエリ]、および[都道府県] > [自分の作業]でフィルタしてクエリを見つけます。
  6. クエリを開き、その SQL を編集して SELECT ステートメントに tn_fraudindicator_ext 列を追加します。
    SELECT
      ...
      claim.dateformretbyemp AS dateformretbyemp,
      claim.tn_fraudindicator_ext AS tn_fraudindicator_ext,  //Column inserted alphabetically
      claim.is_furthertreatment AS is_furthertreatment,
      ...
    FROM
      dd_loss_Claim_trv.dd_loss_claim_trv Claim
      LEFT JOIN dd_loss_user_trv.dd_loss_user_trv User ON claim.assigneduserid = user.id AND   
            claim.updatetime >= user.row_eff_dts AND claim.updatetime < user.row_exp_dts
      LEFT JOIN dd_loss_address_trv.dd_loss_address_trv LossLocationID ON losslocationid.id = 
            claim.losslocationid AND claim.updatetime >= losslocationid.row_eff_dts AND  
            claim.updatetime < losslocationid.row_exp_dts
  7. 一部のクエリには、'nokey' と '?' の値を含む追加の行を生成する UNION 句が含まれています。これらのプレースホルダ値は、ディメンションが存在しない場合に下流で使用されます。次の例に示すように、SQL 検証に合格するために UNION 句に tn_fraudindicator_ext を追加する必要があります。
    重要: UNION 句と SELECT ステートメントで列の順序が同じであることを確認してください。2 つの句の間に相違があると、クエリの実行時にエラーが発生します。
    UNION ALL
    SELECT
      ...
      NULL AS dateformretbyemp,
      CAST('?' AS STRING) AS tn_fraudindicator_ext,          //Column inserted alphabetically
      CAST('?' AS varchar (1)) AS is_furthertreatment,
      ...
  8. クエリを実行して、エラーがないことを確認します。
  9. [アクション] > [保存]を選択します。
    ヒント: Data Studio でのクエリの詳細については、『 Data Studio Guide』を参照してください。

ステップ 3:クエリを Explore に公開する

このタスクについて

クエリを Explore に公開するには、Guidewire が作成した元のパブリケーションにそのクエリを追加します。

手順

パブリケーション名とプロパティを検索する
  1. Data Studio インベントリに移動し、Explore の元のテーブルの名前 efr_dim_claim を検索します。
  2. efr_dim_claim データセットカードで、省略記号を選択して[詳細]を選択します。
  3. データセットに関する次の情報をメモします。
    1. [パブリケーション]で、データセットが属するパブリケーションをメモします。
    2. [データセットのオプション]で、[時間基準]、[主キー]、および[並び替え]をメモします。
クエリを公開する
  1. 作成したクエリ(efr_dim_claim_v1)に戻り、[アクション] > [公開]を選択します。
  2. [既存のパブリケーションですか?]を選択し、元のデータセットが属するパブリケーションの名前を選択します:efr_loss_v0_1_0。
  3. 他のデプロイプロパティを構成し、元のデータセットと一致させます。
    1. 主キー:skey
    2. 時間基準:Current
    3. 並び替え:updatetime
  4. [公開]を選択します。

ステップ 4:新しいデータセットを Explore に追加する

このタスクについて

Explore 接続を更新して新しいデータセットを含める必要があります。これにより、新しいデータセットが Explore で利用可能になります。

以下の手順を実行する前に、公開されたデータセットが接続エディタに表示されるまでに最大で 1 時間待たなければならない場合があります。正確な待機時間は、ボリュームとパブリケーションの数によって異なります。

手順

  1. Explore の[データ]データベースアイコン ワークスペースに移動し、[接続]を選択します。
  2. 接続名を選択して開き、接続の[編集]を選択します。
  3. テーブルの一覧で、 efr_dim_claim_v1 を選択します。これは通常、[explore] > [公開]の下に一覧表示されています。
  4. すべての列を選択して、データセット全体を Explore 接続に追加します。
  5. [接続を更新]を選択します。
    これで、データセットは Explore のテーブルになりました。[データ]データベースアイコン ワークスペースの[データオブジェクト] > [テーブル]に現れます。

ステップ 5:テーブルを結合する

このタスクについて

新しいディメンションテーブルをファクトテーブルに結合して、Explore が関係を理解できるようにする必要があります。テーブルレベルで結合を作成すると、一度作成するだけで済みます。自分や他のユーザーが作成する Explore モデルはこの結合を継承するため、常に正確です。また、テーブルの列プロパティを確認し、必要に応じて調整することもできます。この場合も、テーブルから作成されたモデルは列のプロパティを継承します。通常は、列の種類と集計が正確かどうかを確認することをお勧めします。その他の列プロパティは、後でモデルレベルで編集するのが最適です。

手順

  1. Explore の[データ]データベースアイコン ワークスペースに移動し、 [データオブジェクト] > [テーブル]を選択します。
  2. efr_dim_claim_v1 テーブルの名前を選択します。
  3. 結合を作成するには、[結合] > [結合の追加]を選択し、次のように入力します。
    1. 結合名:fact_to_claim_dim
    2. テーブル 2:efr_fact_loss_calendaryear
    3. テーブル 1 の列:skey
    4. テーブル 2 の列:fk_claimid_skey
    5. 結合タイプ:Left Outer
    6. カーディナリティ: 多対 1
    7. [保存]を選択します。
  4. [列]で、必要に応じて[列の種類]プロパティと[集計]プロパティを編集します。詳細については、モデル列のプロパティを参照してください。
  5. [変更の保存]を選択します。

手順 6:モデルの新しいバージョンを作成する

このタスクについて

新しい列をモデルに追加するには、そのモデルの新しいバージョンを作成する必要があります。ユーザーには、Guidewire が作成したモデルを編集する権限はありません。

手順

  1. 新しいブラウザタブで、以下のページを開いて後で参照できるようにしておきます。
    1. Explore のデータディクショナリドキュメントから、GW - クレームの損害財務 - 暦年モデルのディクショナリを開きます。
    2. 元のモデルを開きます。Explore で、[データ]データベースアイコン ワークスペースに移動し、[データオブジェクト] > [モデル] > [GW - クレームの損害財務 - 暦年]を選択します。
  2. Explore で、[データ]データベースアイコン ワークスペースに移動し、 [新規作成] > [モデル]を選択します。
  3. [Build your own with cloud data] > [次へ]を選択し、接続を選択して[次へ]を選択します。
テーブルを追加する
  1. 元のモデルでブラウザタブを開きます。[結合]を調べて、含まれているファクトテーブルとディメンションテーブルを確認します。
  2. これらのファクトテーブルとディメンションテーブルを新しいモデルに追加します。元のテーブル(efr_dim_claim)ではなく、Data Studio で作成した新しいテーブル(efr_dim_claim_v1)を追加してください。
    1. 各テーブルをドラッグアンドドロップします。特定のテーブルを見つけるには、検索バーを使用するか、タグ別でフィルタするか、リストを並べ替えます。
    2. テーブルレベルで作成された結合は、モデル図に推奨として表示されます。結合アイコン を選択し、[Accept recommended join]を選択します。
      重要: モデル内で結合してもテーブル内では結合していない場合、キャズムトラップが作成されます。キャズムトラップがあると、検索結果内の基盤のデータを表示できなくなります。
列を追加する
  1. モデルのデータディクショナリで、元のモデルの[ソーステーブル]と[ソース列]を参照します。手順 7 から 8 に従って、各列を新しい列 tn_fraudindicator_ext column と共にモデルに追加します。
  2. [列]を選択し、サイドバーでソース列名を検索します。
    1. 列をクリックし、ドラッグして追加します。テーブルからすべての列を追加するには、テーブル名をクリックしてドラッグします。
    2. 既存の列の名前を変更して、ディクショナリの[モデル列名]と一致するようにします。新しい列には、ビジネス向けのわかりやすい名前を付けます。例えば、「詐欺インジケータ」という名前にします。
  3. ディクショナリの[ソース列]に「式」と表示されている場合は、列リストに表示されません。代わりに、式を作成します。
    1. [式]タブを選択し、[式を追加]を選択します。
    2. ディクショナリの[モデル列名]と一致する名前を式に付けます。例えば、「Accounting Period」という名前にします。
    3. データディクショナリから[式]の式をコピーし、式エディタに貼り付けます。
    4. [保存]を選択すると、その式が[列]タブに列として表示されます。
  4. 列を追加したら、赤色でハイライト表示されている列、つまり列名が重複している列がないか確認します。重複する列を削除するか、一意の名前を付けます。
  5. [変更の保存]を選択し、モデルに「クレームの損害財務 - 暦年 - V1」という名前を付けます。
  6. [データモデルを終了]を選択します。

ステップ 7:モデルを共有する

手順

  1. 新しいモデルを開いた状態で、[詳細] > [共有]を選択します。
  2. ユーザーまたはグループを追加し、権限を指定します。次から選択できます。
    Can View モデルのデータを表示できます。
    Can Edit モデルの名前変更、変更、または削除ができます。列を追加または削除できます。

タスクの結果

モデルを共有したすべてのユーザーが、このモデルを使用して検索結果と Liveboards を作成できるようになります。

ステップ 8:Liveboard で新しい列を使用する

このタスクについて

新しい列を標準の Liveboard に追加するには、その Liveboard の新しいバージョンを作成する必要があります。ユーザーには、Guidewire が作成した Liveboard を編集する権限はありません。

手順

Liveboard のコピーを作成する
  1. 元のモデルを開きます。Explore で、[データ]データベースアイコン ワークスペースに移動し、[データオブジェクト] > [モデル] > [GW - クレームの損害財務 - 暦年]を選択します。
  2. [依存]を選択し、暦年損害分析 Liveboard を選択します。
  3. [詳細] > [コピーの作成]を選択し、その Liveboard に「暦年損害分析 V1」という名前を付けます。
Liveboard が新しいモデルを指すようにする
  1. 新しい Liveboard で、[詳細] > [TML] > [編集]を選択します。
  2. [検索] > [検索と置換]を選択します。モデル名のすべてのインスタンスを検索して新しいモデルに変更します。例えば、次のコードのインスタンスが 10 個あるとします。
    tables:
      id: GW - クレームの損害財務 - 暦年
      name: GW - クレームの損害財務 - 暦年
    これを以下で置き換えます。
    tables:
      id: クレームの損害財務 - 暦年 - V1
      name: クレームの損害財務 - 暦年 - V1
  3. [検証]、[公開する]の順に選択します。
ビジュアライゼーションに新しい列を追加する
  1. 新しい Liveboard で、tn_fraudindicator_ext 列を使用するビジュアライゼーションを見つけます。[詳細] > [編集]を選択します。
  2. この列を次のように検索クエリに追加します。
    Claim Number
    Policy Number
    Reported Date daily
    Loss Cause
    Loss Date yearly
    Claim State
    Fraud Indicator              // The new column
    MTD Indemnity Paid
    MTD Gross Expense Paid
    MTD Total Reserve Change
    MTD Total Gross Recovery
  3. [検索]を選択してビジュアライゼーションを更新し、[保存]、[閉じる]の順に選択します。