Explore でのグラフとテーブルの編集

Explore でグラフおよびテーブルの外観を編集できます。データを検索 したり、既存の検索結果を編集したりすると、Explore はデータに最も適していると判断した種類のグラフまたはテーブルを自動的に作成します。その後、ユーザーは自分のニーズに合わせてグラフまたはテーブルを微調整できます。

重要: エディタを閉じる前に変更を保存してください。ビジュアライゼーションの上部にある[詳細] > [保存]を選択します。
重要: 既存の検索結果を表示しているときに、タイトルの横にあるロック は、ユーザーが[表示]アクセスのみを持っていることを意味します。検索を編集することはできますが、変更を保存することはできません。所有者に編集権限を要求するには、ロックを選択します。

全般設定

タイトルと説明
タイトルと説明を選択して編集します。
グラフまたはテーブルの選択
データをグラフとして表示するには、[グラフを表示]を選択します。または、テーブルとして表示するには、[テーブルを表示]を選択します。変更を保存すると、選択したビューが他のユーザーに表示されます。ビジュアライゼーションを開いて編集する権限がない限り、グラフとテーブルの両方は表示されません。
グラフのタイトルの横にあるグラフ/テーブルのトグルが強調表示されたグラフの例

エディタの操作

設定を確認する場所はいくつかあります。


編集可能なコンポーネントのメニューを含むグラフの例。一部には詳細設定があります。その他のオプションを表示するには、グラフを操作します。
1. 編集メニュー
グラフまたはテーブルのコンポーネントごとに 1 つのセクションがあります。各セクションの設定は、グラフまたはテーブルの種類によって異なります。
  • 種類
  • レイアウト
  • 列
  • 軸
  • データラベル
  • ツールチップ
  • 凡例
  • 表示
  • クエリ(グラフの生成に使用したクエリを表示します。編集できません)
2. 詳細設定
編集メニューの一部のセクションでは、[詳細設定]を選択して追加の設定を表示できます。
3. グラフまたはテーブルの操作
一部の設定は、グラフまたはテーブルの特定の要素を選択または右クリックすると表示されます。例えば、軸名を選択すると、設定メニューが表示されます。

グラフの設定

使用可能なグラフの設定の一部を次に示します。

グラフの種類
[種類] を選択し、20 種類以上のグラフの種類から選択します。各種類の詳細については、ThoughtSpot のドキュメント「Chart types」を参照してください。
開発者は、Exploreで直接 Muze Studio コードエディタを使用して、他のグラフの種類を作成できます。Muze グラフは、そのグラフが作成された場所の回答にのみ適用されます。カスタムグラフを再使用するために、他のユーザーが回答のコピーを作成して変更できます。詳細については、ThoughtSpot 開発者向けドキュメント「Muze Studio」を参照してください。
色を変更する
マルチカラーチャートで、凡例項目の色を選択して編集します。
凡例項目を非表示にする
任意の凡例項目を選択して、グラフで非表示または表示します。凡例項目をダブルクリックすると、その項目のみが表示されます。もう一度ダブルクリックすると、すべての項目が表示されます。
軸を切り替える
[レイアウト] を選択し、列をクリックして別の軸にドラッグします。
軸のプロパティを編集する
X 軸または Y 軸を選択してプロパティを編集します。例えば、条件付き書式を追加したり、データをフィルタしたりできます。
データポイントの最大数を設定する
[表示] を選択し、最大データポイント数を入力します。
null 値を非表示にする
[列] > [Hide null values]を選択します。
ツールチップを編集する
データポイントにカーソルを合わせたときに表示されるツールチップに含めるフィールドを選択するには、[ツールチップ] > [編集]を選択します。
データラベルを表示する
グラフにラベルを表示するには、[データラベル] を選択します。
グリッド線を表示する
[軸] を選択し、[軸線]で[Display gridline on chart]を選択します。

テーブル設定

使用可能なテーブルの設定の一部を次に示します。

列のプロパティを編集する
列のプロパティを編集するには、列名にカーソルを合わせ、[詳細]の省略記号を選択します。例えば、テキストの折り返しや条件付き形式をコンフィギュレーションしたり、列の名前を変更することができます。
並び替え列
列を基準に昇順または降順に並べ替えることができます。列名にカーソルを合わせ、[詳細]の省略記号を選択してから、[並べ替え]を選択します。
列を非表示にする
検索内に列を保持したまま、テーブルから列を非表示にできます。[レイアウト] を選択し、列を[表示された列]から[非表示された列]にドラッグします。非表示された列を使用してデータを並べ替えることもできます。

次の操作

ビジュアライゼーションを保存して検索結果を作成し、組織で共有します。